Frequently Asked Question

Comment puis-je choisir la version de PHP sur mon hébergement ?
Last Updated about a month ago

Pour des raisons de compatibilité, nous ne pouvons pas toujours mettre à jour automatiquement la version de php utilisée par votre site, car nous ne pouvons garantir que votre site a été conçu et est compatible avec cette nouvelle version. Il est donc possible que votre hébergement utilise encore une ancienne version de php.

Pour des questions de sécurité, il est malgré tout recommandé que vous mainteniez votre version de PHP à jour en maintenant également votre site pour être compatible.

Les versions de php disponibles pour votre site dépendent de votre serveur d'hébergement. Pour des raisons techniques, les versions plus récentes de php ne sont pas toujours disponibles avec les hébergements les plus anciens, et inversement. N'hésitez pas à prendre contact avec nous si vous souhaitez réinitialiser votre hébergement vers un serveur actuel.

Voici les différentes instructions possibles à placer dans un fichier .htaccess pour choisir une version différente de php :

  • AddHandler x-httpd-php5 .php #php 5.X (déconseillé)
  • AddHandler x-httpd-php56 .php #php 5.6 (déconseillé)
  • AddHandler x-httpd-php7 .php #php 7.X
  • AddHandler x-httpd-php73 .php #php 7.3
  • AddHandler x-httpd-php74 .php #php 7.4 (recommandé)
  • AddHandler x-httpd-php8 .php #php 8.X
  • AddHandler x-httpd-php80 .php #php 8.0 (recommandé)

Vous pouvez vérifier la version de php actuelle de votre site avec phpversion() ou avec phpinfo().

Petit rappel des versions php officiellement supportées par l'équipe php : https://www.php.net/supported-versions.php

Please Wait!

Please wait... it will take a second!